TheCoatingStore.com

Results 1 to 4 of 4

Thread: My Devilbiss GFG-670 Plus is not spraying evenly.....why?

  1. #1

    Default My Devilbiss GFG-670 Plus is not spraying evenly.....why?

    The last time I used it, it was sputtering, or pulsating. What would cause that? The gun is about 11 years old.

  2. #2
    Join Date
    Nov 2013
    Location
    olympia,wa
    Posts
    802

    Default

    sputtering is usually caused by either blocked vents in the cup or the fluid nozzle is not sealed well. some guns i've had needed to be unreasonably tight where the nozzle attaches to the body to spray correctly.
    b marler

  3. #3
    Join Date
    Nov 2005
    Posts
    40,592

    Default

    Quote Originally Posted by sykotic View Post
    The last time I used it, it was sputtering, or pulsating. What would cause that? The gun is about 11 years old.
    Check out the parts behind the fluid tip if anything is damaged it would cost around $90 to replace everything shown below. The rear most seal comes in a pack of 5 for $22 at this time.


  4. #4

    Default

    Thanks, guys. I found a 5 pack of those seals on amazon. I looked closely at my seal, the baffle piece, and the fluid tip, and they all look ok, but since its 11 years old, it can't hurt to put in a fresh seal. I stumbled upon the GFG-670 data sheet online, and it shows that I'm supposed to torque down the tip to 12 to 15 ft. lbs. I couldn't tell you if I've ever had it that tight. That might be part of the problem! I have a torque wrench, so I'll use it from now on.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •