TheCoatingStore.com

Page 1 of 2 12 LastLast
Results 1 to 15 of 17

Thread: "Basics of Basics" Convertible Top pump/motor disassembly and rebuild

  1. #1
    Join Date
    Nov 2005
    Location
    San Francisco bay area California
    Posts
    13,046

    Default "Basics of Basics" Convertible Top pump/motor disassembly and rebuild

    “Basics of Basics” Convertible top pump/motor rebuild
    By Brian Martin

    This “Basics” is more about demystifying the convertible pump system than anything else. I got the pump/motor back in my car and working so fast and with such excitement that I didn’t take any photos at all. So in deciding to put together a little “Basics” on the subject I just went and snapped some shots of the extra pump/motor I had. When I decided to pull mine apart I did a little google search and found nothing what so ever, thus the need for this “Basics”.
    Where it all began…..I was putting my 1965 Buick Gran Sport convertible back together after about 12 years apart. Everything was finished on the car and being I am no mechanic I did the body and paint and left the convertible top stuff for the very end. To tell you the truth, I was pretty intimidated by it, but finally dug into it. The first thing I did was to install the rams that I purchased 12 years ago. The system worked when I pulled it apart and I forget why I even bought the new rams but I had them non-the-less. I got the motor and lines out of the rafters and blew out the lines with compressed air after removing them so I wouldn’t be dripping brake fluid all over my beautiful paint. I installed the rams and pump/motor and put in some new brake fluid (I HATE working with this stuff around paint!) and hit the switch……nothing. I mean nothing what so ever, not even a sound. After some diagnosis work I determined the pump/motor was the problem so I started thinking about buying a new one, which I found out was a off shore “generic” and I wasn’t going to have any part in that. And me being cheaper than snot I figured, I would pull the thing apart and see what it’s all about. I had a spare (a little newer, it had a rubber fill plug instead of the screw the original had) and decided to learn on the spare. These photos are of the original pump/motor so you will see the screw in fill plug in photo #2. We start with photo #1, these are the two bolts that hold the motor onto the pump. They are a ľ” headed bolt about 4 inches long that goes right past the magnets on the sides of the armature and screw into the pump body.



    In photo #2 you can see the standard screw driver headed fill plug and the bolt that holds the reservoir to the pump. It’s simply an approx 3” long bolt that goes thru the middle of the reservoir into the pump. That bolt head looks pretty odd but a regular 11/16 open end wrench works on it.



    The reservoir has a large O ring that seals it, (seen in photo #16) and a small O ring at the head of the bolt. (Photos# 16 & 17). When you remove that bolt and pull the reservoir off you will find the top of the pump as seen in photo #3. Remove the five quarter inch 7/16” headed bolts and you will have photo #4 and the pump it’s self photo# 5. You my have noticed if you looked at the photos that there is no gasket, it simply bolts right to the pump with the two aluminum surfaces being perfectly flat.



    Last edited by MARTINSR; 04-19-2012 at 12:35 AM.

  2. #2
    Join Date
    Nov 2005
    Location
    San Francisco bay area California
    Posts
    13,046

    Default



    Photo #6 shows two of the only four moving parts in the pump (it’s crazy simple guys). I honestly don’t know what to call them. The larger ring looking piece goes in the hole in the pump, while the little star looking piece slips into the ring and over the end of the armature seen in the pump, refer back to photo #5. I ended up using parts from both pump/motors to make one. The ring thingie you see was so stuck in the replacement pump that I couldn’t get it out. I pulled the one out of the car at that point so I could get them both apart and see what parts I need. I ended up hammering a bolt into that ring so I could twist it and get it out of the pump. If this was the only one I had, I would have had to find another way. But to tell you the truth, I tried quite a bit before I resorted to the bolt. You can’t see it in the pictures because I have the bad part facing down. But I did ruin this piece. The original pump was stuck too, but I was able to get the piece out after a little coaxing. This was why the original motor didn’t turn. The pump was locked up solid! I have to assume the “rebuild kit” they sell for these motors would include this ring and star piece.




    You can see the two ball bearings that go in the pump cover in photo #7. These ball bearings are what controls the fluid, directing the fluid to the hoses that will carry it to the bottom of the rams raising your top, or to the hoses that will carry the it to the top of the rams lowering the top.



    In photo #8 you can see the round hole where that ring and star sit and the little O ring that seals the armature shaft as it comes into the pump. You can also see the passages that the fluid goes thru being pushed by the pump into the respective hoses.

    Last edited by MARTINSR; 04-19-2012 at 12:36 AM.

  3. #3
    Join Date
    Nov 2005
    Location
    San Francisco bay area California
    Posts
    13,046

    Default

    These passages need to be cleared. They will likely have crusty gunk in there from loose chunks that fall right out to rock hard stuff that needs to be “chiseled” out with a sharp tool. Breaking this junk up and blowing it out with compressed air works like a charm. Cleaning out all the junk in these passages, where the two ball bearings are, and replacing the O rings at the armature, hose fittings, and if you want the reservoir and fill plug is all there is to “rebuilding” the pump! That’s it guys, it is that easy!



    On to the motor portion and photo #9. After removing the two long bolts mentioned in photo #1 the motor pulls off the pump. Those two screws are the only thing holding it on. There is no gasket or seal, it simply pulls off easily. You can see in the photo a small washer on the armature (a rusty washer in this case), that is one of only four pieces that come out of the motor. Photo #10 shows the end of the motor with the brushes, and photo #11 shows the ball bearing that sits in the end of the armature and a little disc that sits at the bottom of the hole the armature goes in and the bearing rides on it.





    To put the motor back together you have to be able to hold the brushes back to slip the armature in. The little disc can simply be dropped into place, the bearing I put a tiny bit of grease on it to hold it to the armature so insure it was in correctly. The next thing is those darn brushes, I got two paper clips and bend them as shown in photo #12. Obviously this isn’t rocket science so they look quite different from one an other but did a perfect job. As seen in photos #13-A and 13-B. Photo #14 shows the motor with the armature in place with the paper clips still there. After this point, you simply pull the paper clips out and there you have it.


  4. #4
    Join Date
    Nov 2005
    Location
    San Francisco bay area California
    Posts
    13,046

    Default





    The bolts that hold the motor together are honestly the only tough part to reinstall. You have to play quite a bit (at least I did) before I could get those buggers started into their threaded holes. Photo #15 shows how they pass thru the motor right next to the magnets. Sorry for the poor photo I just wanted to add it to demystify this darn bolt. You can see at the top of the photo a little half round pocket in the magnet where the bolt fits down to the pump on the other end of the motor.


  5. #5
    Join Date
    Nov 2005
    Location
    San Francisco bay area California
    Posts
    13,046

    Default

    Photo numbers 16, 17, 18 and 19 simply show the seals that are in the pump/motor assembly. I found them all in the A/C O ring assortment at the parts store. The large one I found that goes around the motor was smaller than the original and would have stretched out and worked but I just left the original there and it worked like a charm.





  6. #6
    Join Date
    Nov 2005
    Location
    San Francisco bay area California
    Posts
    13,046

    Default

    This is what the pump reservoir looked like on my original pump! Darn good thing the motor and pump didnít work or I would have pumped this crap into my new cylinders!


    Yes it is a darn good thing I went ahead and pulled the pump apart and rebuilt it. It worked the first time I tried it, just hooked it back up and turned the switch and wham, I had a working top pump/motor again. The other very good thing that came from it was I changed it out to run automatic transmission fluid, I am MUCH happier with something that wonít eat any paint like aircraft paint stripper!

    It was also learned that these motors are very generic and all cars made for a number of decades from all manufacturers have very similar pump/motors.

    I canít believe that I was so intimidated by this whole thing, it was so damn simple I was blown away. I had it back and running in the car so fast I didnít even have time to think. Now darn it, go out there in the garage and get yours working, itís almost summer!

  7. #7
    Join Date
    Dec 2005
    Location
    Moochville
    Posts
    28,740

    Default

    Very nice post Brian .That type of motor isn't as easy to work on . Having the brushes recessed so much .

    Having worked a few years in an electric motor repair shop i speak from experience .

    Mooch

  8. #8

    Default

    I really appreciate this thread. I was putting off taking apart the pump/motor on the 64 corvair spyder convertible that I have been working on. But after this Basic of Basics I took it apart this morning with no problems. Thank you many times over. Did you reuse the clear plastic hoses or put on new ones? The motor/pump I have been working on was setting since 1972 so it was really cruddy.

    Dennis D.

  9. #9
    Join Date
    Nov 2005
    Location
    San Francisco bay area California
    Posts
    13,046

    Default

    That is exactly why I wrote it, I was so stunned at how easy it was after being so intimidated before I opened it up I figured it would be of help to others. I'm so glad to hear it was of value to you!

    I reused everything except the smaller O rings on the lines at the motor and on the bolt that holds the reservoir on.

    I hope the top iron alignment and putting the top on is as surprisingly easy as this pump/motor!

    Mooch, but check it out, I was really worried about the brushes but with the paper clips holding them it worked like a charm. Not even a hick-up, I put it together and installed it and hit the switch and off it went.

    Brian

  10. #10
    Join Date
    Dec 2005
    Location
    Moochville
    Posts
    28,740

    Default

    Quote Originally Posted by MARTINSR View Post
    That is exactly why I wrote it, I was so stunned at how easy it was after being so intimidated before I opened it up I figured it would be of help to others. I'm so glad to hear it was of value to you!

    I reused everything except the smaller O rings on the lines at the motor and on the bolt that holds the reservoir on.

    I hope the top iron alignment and putting the top on is as surprisingly easy as this pump/motor!

    Mooch, but check it out, I was really worried about the brushes but with the paper clips holding them it worked like a charm. Not even a hick-up, I put it together and installed it and hit the switch and off it went.

    Brian
    I did check it out .Clips worked good . On most motors you can install the brushes and put the springs in from the rear . But that one you would never be able to .

    Mooch

  11. #11
    Join Date
    Nov 2005
    Location
    San Francisco bay area California
    Posts
    13,046

    Default

    Quote Originally Posted by Mooch View Post
    I did check it out .Clips worked good . On most motors you can install the brushes and put the springs in from the rear . But that one you would never be able to .

    Mooch
    I always like to ask myself when I am having a hard time taking something apart or putting it together the simple question, "How was this done at the factory?"

    With this one, I have no friggin idea! I am thinking they did something similar to what I did.

    Brian

  12. #12
    Join Date
    Dec 2005
    Location
    Moochville
    Posts
    28,740

    Default

    Quote Originally Posted by MARTINSR View Post
    I always like to ask myself when I am having a hard time taking something apart or putting it together the simple question, "How was this done at the factory?"

    With this one, I have no friggin idea! I am thinking they did something similar to what I did.

    Brian
    I'm sure they had a special little tool that did what you did .

    Mooch

  13. #13
    Join Date
    Nov 2005
    Location
    San Francisco bay area California
    Posts
    13,046

    Default

    Ok, off to the cylinders!

    A number of people requested a "demystification" of the cylinders. Well, I was going to toss them and I am glad I didn't. I certainly don't have any knowledge in the subject so what you see is what you get.

    Starting with photo B you will see that cut a slit around the tube that makes up the cyl. I should have taken a better photo before I did this but was so damn excited to cut it open and see what was inside.

    It is crimped at the top, pretty tough to reproduce this at home. I am thinking that you could possible make a pair of dies that could do this in a vice. But it's asking for a lot, pretty tough to pull it off if you ask me.



    Photo C is a close up of the "piston" in the cyl.



    Photo D shows me prying the top of the tube off the upper piece. And E shows what the piece looks like when off.



  14. #14
    Join Date
    Nov 2005
    Location
    San Francisco bay area California
    Posts
    13,046

    Default

    And G shows the assy overall. There is no "F" photo so don't think I there is one missing. I messed up when I was putting the letters on them.



    Photo H shows how the tube would go back onto the upper piece if you wanted to try crimping it.

    \

    I cut the bottom of the tube off so it can be seen.(photo I) The hose hooks to the side of that "donut" area inside. The nut and then end of the rod goes down into that area in the middle of the donut when it goes all the way down. This is one thing I wonder about, if you were to cut the tube off like I did and re-crimp it, it's going to be a quarter inch (or so) shorter, will this interfere with the operation of the cylinder? Photo J shows the two side by side, will the shortening effect it, I am thinking not, but I don't know.



  15. #15
    Join Date
    Nov 2005
    Location
    San Francisco bay area California
    Posts
    13,046

    Default


    Photo K shows the piston and the O ring seal.



    The top piece of the cylinder shows a snap ring that needs to be removed to get the seal out as seen in photo L. The seal is an odd one, it's like a hollow washer with a plastic like washer inside. I am assuming this is needed for the high pressure that it is subjected to.



    In photo L you can also see the O ring that goes around the top of it to seal the tube when it is crimped on.

    I don't know guys, if you are willing to try rebuilding one, you are tougher than me. I would still buy new ones and spend that time on getting the car done, it's almost summer!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •